Follow

Why can’t I see Tournaments?

To play Tournaments you need to have version 3.45.0 or higher.

Was this article helpful?
3 out of 48 found this helpful
Have more questions? Submit a request